ssd Question NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Replied by sdefrwggerg on topic NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted 1 year 3 months ago #721
You can write your own Configuration by selecting the menu bar Dump --> Show Device Info in the tool, open the existing Config file with text Editor chage the Settings and save it as a new new.cfg file.
jeyi is using RTL9210B v1.32.16 and GDFW v4.30.23.071922


RTL9210A 1.29.8 / RTL9210B 1.32.16 / GDFW 4.30.23.071922 / MPTOOL 1.14.8.0610 / MPTOOL Lite 1.15.0.0711 with all Config
The following user(s) said Thank You: wade7575

Please Log in or Create an account to join the conversation.

Replied by wade7575 on topic NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted 1 year 3 months ago #722
@sdefrwggerg I was able to flash my Unionsine ssd enclosure with RTL9210B_CG_Lite.cfg configure file and when I opened it in text editor these are the setting's below.

DISK_HOTPLUG = 0x0
LED = 0x1
PINMUX1 = 0x0
PINMUX2 = 0x70
U2_MAXPWR = 0xfa
U3_MAXPWR = 0x70
ASPMDIS = 0x0

;5 minutes of idle time will disable pcie power
DISK_IPS_THRES = 5

;EN_UPS = 0x0
;PD = 0x0

;CUSTOMIZED_LED is 15 bytes
;CUSTOMIZED_LED = 01 01 
;SUSPEND_LED_OFF = 0x0
FAN = 0x1

DIS_SHOW_EMPTY_DISK = 0x1
;FORCE_SATA_NORMAL_DMA = 0x0
UART_DBG_PIN = 5
;FINGER_PRINT_EN = n

;=================Tool Configure=================
;DISCONN_FORCE_USB2 = n
FORMAT_DISK = n
;INC_SERIAL = y

;PARTITION: GPT, MBR
PARTITION = "MBR"
;FORMAT: NTFS, exFAT
FORMAT = "NTFS"
;LABEL max allowed - characters
LABEL = "My USB"

But after flashing the RTL9210B with RTL9210B_CG_Lite.cfg file and v1.32.16.010923 firmware and I go in and check the dum file info on the device it looks like this and almost everything is set to n/a

PD : n/a
CUSTOMIZED_LED : n/a
SUSPEND_LED_OFF : n/a
FORCE_USB_SPEED : n/a
FORCE_PCIE_SPEED : n/a
EN_U1U2 : n/a
FORCE_USB_QUIRK : n/a
FORCE_PCIE_QUIRK : n/a
FAN : 0x00000001
DIS_SHOW_EMPTY_DISK : 0x01
FORCE_SATA_NORMAL_DMA : n/a
UART_DBG_PIN : 0x05
FINGER_PRINT_EN : n/a
RM_INTERNAL_RD : n/a
HS_AUTO_SWITCH : n/a
UART_BAUD_RATE : n/a
CUSTOMIZED_DISK_IDENTIFY : n/a
HW_LED_CFG : n/a
CDROM_CFG : n/a
SUPPORT_HID : n/a
LATE_INIT_DISK : n/a
SCSI_WP_PIN : n/a
SD_MMC_TYPE : n/a
FORCE_PORT_TYPE : n/a
BCDDEVICE : n/a
SUSPEND_DISK_OFF : n/a
SCSI_WB_PIN : n/a
CUSTOMIZED_FEATURE : n/a

Boot Mode : Flash
FW Ver : 1.32.16
FW Build Date : 2023.01.09
IC Pkg Type : PCIE_SATA
UUID : n/a

Disconn_ForceUSB2 : false


 

Please Log in or Create an account to join the conversation.

Replied by wade7575 on topic NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted 1 year 3 months ago #723
What I'm trying to understand why setting for the led didn't transfer over when I flashed my RTL9210B,I also don't understand that when I loaded the RTL9210B_CG_Lite.cfg it seems like know of the file never got loaded into the program although it showed that it did.

Please Log in or Create an account to join the conversation.

Replied by sdefrwggerg on topic NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted 1 year 2 months ago #725
0x0 = off = n/a

;
If this ; character placed before the setting (To comment the setting). When commented the default value for this setting is applied by the machine OS/Bios. If default is n/a it will be always set as n/a


You need only this Setting Led light on all the time and flashes when it works, as opposed to no light when not in use
RM_INTERNAL_RD = 0x1 without ;
Last Edit:1 year 2 months ago by sdefrwggerg
Last edit: 1 year 2 months ago by sdefrwggerg.
The following user(s) said Thank You: wade7575

Please Log in or Create an account to join the conversation.

Replied by mushroom on topic NVME USB drives Realtek RTL9210/RTL9220 Firmware Version 1.xx

Posted 1 year 2 months ago #805
Hello

I have a K1685P4 RTL9210B Enclosure. It came with Firmware 1.24.xx and had a lot of trouble with working under Linux.

Thus, I tried updating the Firmware to 1.27.xx. But the update failed, and the Enclosure isn't detected properly anymore since via USB.

The WCH Controller for the RGB lights is still recognized, but the RTL Controller not. I'm also not sure how it mixes the WCH Controller and RTL Controller. To my understanding, the WCH Controller is connected via USB2.0 to the RTL Controller and this one bypasses it over USB3.2 to the Host.

This theory would also result that the RTL Controller is still working. But I don't get anything RTL related detected over USB.

This is the dmesg result:
Code:
[ 8645.088472] usb 2-1: new full-speed USB device number 15 using xhci_hcd [ 8645.248430] usb 2-1: New USB device found, idVendor=1a96, idProduct=e010, bcdDevice=13.00 [ 8645.248435] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [ 8645.248436] usb 2-1: Product: HID To Serial [ 8645.248437] usb 2-1: Manufacturer: WCH.CN \x13 [ 8645.248438] usb 2-1: SerialNumber: 12345678 [ 8645.281767] hid-generic 0003:1A96:E010.0005: hiddev96,hidraw1: USB HID v1.00 Device [WCH.CN \x13 HID To Serial] on usb-0000:05:00.4-1/input0


Any idea what I could try?

I have already tried the following things:
- Connect VSS and CS on the SPI Flash to reprogram it over Update utility (no RTL chip detected over USB)
- Erased the SPI Flash with a BIOS Programmer
- Entered Download Mode with connecting the Download Pins. This puts the WCH Controller into Downloading mode.
- Holding the WCH Controller in Reset.

 
 
Last Edit:1 year 2 months ago by mushroom
Last edit: 1 year 2 months ago by mushroom.

Please Log in or Create an account to join the conversation.

Time to create page: 1.074 seconds
Powered by Kunena Forum