Station-Drivers - [DRIVERS] Realtek High Definition Audio Codecs (HDA/UAD) - Page 229 - STATION-DRIVERS

[DRIVERS] Realtek High Definition Audio Codecs (HDA/UAD)

More
3 months 1 day ago - 3 months 1 day ago #3816 by erpster96

Melchior wrote: I have a ASUS PRIME mobo...so the v6.0.8996.1 drivers are not for my mobo... I checked his thread a while ago..
thx anyway Erpster96


you can do better than that, Melchior.
there are MANY kinds of Asus PRIME motherboards (like PRIME X299-A, PRIME X570-PRO, PRIME H310M, PRIME Z490-A, etc....you get the point) - c'mon man - what is the specific model of your ASUS motherboard?

edit 8/29 - in the meantime, use this v6.0.8971.1 UAD ASUS driver direct from Asus web site as it has the HDXASUS.inf & HDX_AsusExt_RTK.inf files (I recently found out that the HDX_AsusExt_RTK.inf extension INF file is not included in Mokichu's 8996 UAD Asus driver as it targets ASUS "ROG" motherboards, not for "PRIME" boards and has only the HDX_AsusExt_AVO_RTK.inf extension INF file for ROG boards using Sonic Studio 3)


btw, Mokichu also made an 8996 UAD Gigabyte driver from this Nahimic support forum thread that I'm using on my Gigabyte board (it's a GA-78LMT-USB3 R2 board using Realtek HD audio ALC892 chipset with hardware device ID "HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_1458A182" - at least I mentioned what mobo model I use and the Realtek audio hardware ID number assigned to that Gigabyte board)

----

moving on,

v6.0.8988.1 UAD (All OEM, non-generic) from MS Update [posted 8/28/2020] - (drivers only)
https://www.catalog.update.microsoft.com/Search.aspx?q=6.0.8988.1
Last edit: 3 months 1 day ago by erpster96.

Please Log in or Create an account to join the conversation.

More
3 months 13 hours ago - 3 months 13 hours ago #3822 by Melchior
erpster96
right...
I have a ASUS PRIME x570-PRO mobo...
I have ASUS/Realtek UAD driver v6.0.8971.1 installed currently...
Last edit: 3 months 13 hours ago by Melchior.

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #3832 by bobbo90
Hello, first of all i'd like to thank you for the awesome job you guys do delivering updated drivers.

I have an Asrock Z97M Pro4 with Realtek Alc892
( Hardware Id HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_1849C892&REV_1003)

I have an old HDA driver (i think a generic FF00 one not sure), what would be the best driver to update to ?
Also is it possible (if it's worth it) to install an UAD one ?

Thanks

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #3835 by gacman
Hello,
Couple months ago, after windows update my soundcard stopped working. I've tried many different versions of Realtek drivers, but none fixed my problem. I think it's not broken, since i see it in EFI and I can even choose beetwen HD/AC97 working mode. Anyway, I'm sitting with 10$ usb soundcard now, straight from china. So, i figured that i'm gonna give it last try and ask you for help before I invest into something better.

My hw/sw specs:
Win10 2004
ASRock Z87 Pro4
HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_18498892

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago - 2 months 4 weeks ago #3838 by erpster96

bobbo90 wrote: Hello, first of all i'd like to thank you for the awesome job you guys do delivering updated drivers.

I have an Asrock Z97M Pro4 with Realtek Alc892
( Hardware Id HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_1849C892&REV_1003)

I have an old HDA driver (i think a generic FF00 one not sure), what would be the best driver to update to ?
Also is it possible (if it's worth it) to install an UAD one ?

Thanks


@bobbo90

HWID " HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_1849C892 " is mentioned in the HDXSRSA.inf file of the HDA (non-UAD) driver, so stick with using standard HDA drivers. official UAD drivers do NOT have that specific ID listed in any INF file so avoid using UAD drivers.

I have a generic 8947 HDA FF00 X64 driver recently available from here . install & use 8947 HDA FF00 on your ASRock board.
Last edit: 2 months 4 weeks ago by erpster96.

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #3839 by erpster96

gacman wrote: Hello,
Couple months ago, after windows update my soundcard stopped working. I've tried many different versions of Realtek drivers, but none fixed my problem. I think it's not broken, since i see it in EFI and I can even choose beetwen HD/AC97 working mode. Anyway, I'm sitting with 10$ usb soundcard now, straight from china. So, i figured that i'm gonna give it last try and ask you for help before I invest into something better.

My hw/sw specs:
Win10 2004
ASRock Z87 Pro4
HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_18498892


@gacman

ok HWID " HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_18498892 " is listed in the HDXRT4.inf file of the HDA driver, so use standard HDA FF00 drivers and avoid using UAD drivers as I told bobbo90. see my previous post on obtaining the generic 6.0.8947.1 FF00 HDA driver

----

moving on


v6.0.8991.1 UAD Lenovo + Dolby SWC + Forte SWC driver from Lenovo (for Lenovo ideapad 5-14ARE05) [posted 8/30/2020]

AND

v6.0.8991.1 UAD "All OEM" driver from MS Update (posted 9/2/2020):
https://www.catalog.update.microsoft.com/Search.aspx?q=6.0.8991.1

Please Log in or Create an account to join the conversation.

Time to create page: 0.212 seconds