To continue, we need donations, thank you for your generosity 

 

 

Votre publicité ici

Asmedia ASM-104x/107x Drivers Version 1.16.44.1 WHQL issue

  • fccard
  • fccard's Avatar Topic Author
  • Visitor
  • Visitor
1 year 3 months ago - 1 year 3 months ago #14385 by fccard
fccard created the topic: Asmedia ASM-104x/107x Drivers Version 1.16.44.1 WHQL issue
Hello there,
Sorry if I'm posting on a wrong place or if this subject has been answered somewhere else. I'm new to the forum. Also sorry if English is not allowed here, I don't speak French.
So I always come to SD for looking new drivers/firmwares. I finally signed to the forum after a problem I had recently with that specific asmedia driver and I hope someone can help me here. The problem is that this driver v1.16.44.1 doesn't work for me. We can find it here: www.station-drivers.com/index.php?option...info&id=2724&lang=en
It installs fine and "Device Manager" says it's Ok but nothing connected to that USB will work (pendrivers, headsets, joysticks, etc). The latest working version is v1.16.41.3. I'm on Win10Pro x64 14393 (latest version) and my motherboard is Asus Maximus V Gene, chipset Z77.
I saw someone having exactly same issue and they asked him if he had the latest firmware installed and that could be the reason. I remember that I had its firmware upgraded once long time ago (over 2 years). I cant remember the exactly version was that. I see here a new firmware www.station-drivers.com/index.php?option...info&id=2279&lang=en and I really would like to hear from you guys if that is 100% compatible with my system or not even when it says it's from HP. So can I install it on my PC without damaging it? Will that allow me to install and use latest 1.16.44.1 driver?
Thanks in advance.
Last edit: 1 year 3 months ago by admin.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago - 1 year 3 months ago #14386 by admin
Asmedia ASM-104x/107x Drivers Version 1.16.44.1 WHQL issue
Hi,
Hi you have ben done to ask the question here
I reassure you the firmware will automatically defer if it needs to update or not your chipset :)

article:
www.station-drivers.com/index.php?option...6&Itemid=171&lang=fr
Last edit: 1 year 3 months ago by admin.

Please Log in or Create an account to join the conversation.

  • fccard
  • fccard's Avatar Topic Author
  • Visitor
  • Visitor
1 year 3 months ago - 1 year 3 months ago #14387 by fccard
Asmedia ASM-104x/107x Drivers Version 1.16.44.1 WHQL issue

admin wrote: Hi,
Hi you have ben done to ask the question here
I reassure you the firmware will automatically defer if it needs to update or not your chipset :)

article:
www.station-drivers.com/index.php?option...6&Itemid=171&lang=fr


Hello there, admin.
Thank you for your reply.
So, I'm not sure if I did not understand what you saying to me or if I did explain badly my case. English is not my main language.
You gave me that link for a Asmedia ASM-1142 USB 3.1 firmware and you saying that's the right one for my Asus Maximus V Gene? As far as I know, the Asmedia chip present on my motherboard is ASM-1042A - if I'm not wrong - and it's for USB 3.0, not 3.1.
What I tried to say is that the latest driver for ASM-1042A, version 1.16.44.1, does not work for me and other members complained about same issue. The latest working driver version for me was 1.16.41.3. All the others after that does not work as I said before.
So I'm wondering if I upgrade the firmware for my Asmedia ASM-1042A chip to the last version available - 131025_10_11_23 - will I be able to install the latest drivers for it? Also I would like to know if that specific firmware is the right one to install on my PC. I need to be very sure about it because, as you know, installing a non-compatible firmware may break the chip forever...
Again, thank you for the help. If anyone else have a solution for it and would like to share, it would be very appreciated.
Last edit: 1 year 3 months ago by fccard.

Please Log in or Create an account to join the conversation.

More
1 year 3 months ago #14388 by admin
Asmedia ASM-104x/107x Drivers Version 1.16.44.1 WHQL issue
The above page was an example of the automatic update
If the old drivers worked, it is quite possible that there exists with the last a bug
But I advise you to update your firmware ASM1042 for a good functioning
www.station-drivers.com/index.php?option...elect&id=461&lang=fr
The following user(s) said Thank You: fccard

Please Log in or Create an account to join the conversation.

  • fccard
  • fccard's Avatar Topic Author
  • Visitor
  • Visitor
1 year 3 months ago - 1 year 3 months ago #14389 by fccard
Asmedia ASM-104x/107x Drivers Version 1.16.44.1 WHQL issue

admin wrote: The above page was an example of the automatic update
If the old drivers worked, it is quite possible that there exists with the last a bug
But I advise you to update your firmware ASM1042 for a good functioning
www.station-drivers.com/index.php?option...elect&id=461&lang=fr


Ok admin,
So that means it's the right one for me. All I have to do is run the "run.bat" file? Or should I go for the "ASM104FWUpdate.exe"? Need to run as admin? Can I run it while on windows or need to be on prompt? Will it create a backup of the actual installed firmware so I can reinstall it in case of problems? Will the "ASM104FWUpdate.exe" avoid installation if the firmware is not compatible for security?
Sorry for all the questions. I just can't afford to break my motherboard :)
Again, thank you.
Last edit: 1 year 3 months ago by fccard.

Please Log in or Create an account to join the conversation.

Time to create page: 0.148 seconds